"Install a local driver" function not working.

Information

Graphics card
Nvidia Geforce GTX 1070m
Windows Version
Microsoft Windows 10
NV-Updater Version
0.6.5.0

Description

When trying to "Install a local driver", after choosing *.exe file, there's an instant flash of progress bar, which disappears and nothing happens. Tried multiple different versions: 511.72 hotfix, 511.23 and 497.29.

Files

Entry relationships

Comments

  • code expanded and checked in

  • I tried actually the hotfix and its working for me. Can you provide me the log file and a screenshot of your settings :)?

    Like 1
    • updated original post with log attachments, at the moment of making a ticket I used 511.65, which I uninstalled with DDU and I'm currently using 511.23 made with NVCleanstall, because 511.65 and 511.72, have driver crashes while launching games with double monitor setup

      Thanks 1
    • I just looked at the log file, there is an error when extracting the setup file. Code 2 means according to 7Zip documentation that it is a fatal error. Now it will be difficult to find out why this is happening, I would imagine the path is too long as it is a commandline tool. Can you try to save the file in a shorter path and run it again?


      Thank you 🙂

    • after moving a file to C drive directly

      (C:/511.23-notebook-win10-win11-64bit-international-dch-whql.exe)

      everything seems to work as normal, it must be an issue with the length of the path as you mentioned, even when I tried to change the file name to contain a maximum number of characters allowed by Windows, process works normally, so it has to be path length alone, maybe to avoid this issue in the future the NV Updater could copy the chosen file into temporary directory that will always work

      Thanks 1
    • Thanks for trying it out 🙂 I almost thought it could only be that. Your tip is a good idea, I will include it as a fix for the next version. Might take a while as I am testing 0.6.6.0 with a new method to find hotfixes.

      Thanks 1